Incorrect "num_found" in search results

A minor bug: the reported “num_found” in search results is sometimes less than the number actually found and shown. Example search:

This produces 5 results but has num_found = 3. I guess this is because the number of distinct dataset codes is just 3: of the 5 results, three have code = “BOP”. But in fact these are all different datasets: IMF/BOP, CEPII/BOP and ECB/BOP (plus Eurostat/bop_rem6 and WB/WDI to make 5 results).

Hi @acottrell,

thanks for your report!

Since you published your message, it seems that the API response is now correct. Perhaps this is a (positive) side-effect of fixing the /search API with pagination (see your other topic).

Can you confirm it meets your expectations now?



Yes, the “num_found” value now agrees with the number of matching datasets returned. Rerunning the query I cited, I now get num_found = 3 with results ECB/BOP, Eurostat/bop_rem6 and WB/WDI.

Perhaps this is due to purging of non-existent data from the search results? When I tried this search previously IMF/BOP was one of the five results I got, but it turned out no TSV file could be found for any of the matching series in that dataset.

I think so. Last month we faced an issue with obsolete search results data in our search engine, and we fixed it.